Problema entre Empathy 3.2.0.1 y protocolo MSN (en LMDE o Debian)

Desde hace una semana mas o menos que estoy usando Gnome-Shell y la verdad es que no me decepcionó. Si bien faltan pulir varios detalles, creo que en lineas generales el proyecto va bien encaminado: Tenemos simpleza, gestos de ratón, escritorios y menús pensados para usuarios, etc.

La cosa es que como estaba con toda la onda de probar cosas nuevas, decidí darle otra oportunidad a Empathy, un mensajero que me había decepcionado bastante en el pasado, pero considerando que la nueva versión venía integrada a Gnome-shell  le volví a dar otra oportunidad. Lo instalé de la siguiente manera:

$sudo apt-get install empathy telepathy-butterfly

(el paquete telepathy-butterfly es el necesario para que funcione el protocolo M$N)

La cosa es que al tratar de hacerlo funcionar, me conectaban las cuentas jabber (gtalk, jabberes, etc.) pero no habia forma de hacer arrancar msn. Después de mucho vueltear (y putear) el problema lo solucioné modificando las siguientes líneas:

$sudo gedit /usr/share/pyshared/papyon/service/description/AB/__init__.py

Y dentro del archivo cambiamos la línea 23 que dice:

url = “http://contacts.msn.com/abservice/abservice.asmx

por

url = “http://local-bay.contacts.msn.com/abservice/abservice.asmx

 

Cerramos y volvemos a abrir Empathy  y ya podemos chatear con nuestros amigos que todavía no son libres. :).

La solución la saqué de acá

En mi humilde opinión, creo que el problema se debe a los cambios en el protocolo que el señor Bill hace sin anuncio. Las desgracias del software privativo.

PD: El empathy queda ejecutándose en segundo plano, por lo que la mejor solución es matar el proceso desde el monitor de sistema o similar.

 

Instalar Iceweasel (Firefox) 4.0.1 en LMDE

Estuve buscando mucho sobre como instalar Firefox 4 en LMDE. No pude encontrar nada sobre como instalar Firefox 4, pero si encontré la forma de Instalar el primo hermano Iceweasel en su versión 4.0.1. Básicamente lo que si fue lo siguiente:

1) Agregué en /etc/apt/source.list el repositorio deb http://mozilla.debian.net/ squeeze-backports iceweasel-4.0 . Mi source.list quedó así:

deb http://linux-mint.froonix.org/ debian main upstream import romeo backport
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
deb http://mozilla.debian.net/ squeeze-backports iceweasel-4.0

2) Hice un sudo aptitude update y luego instalé con sudo aptitude install iceweasel. Acá me chilló con lo siguiente:

No se satisfacen las dependencias de los siguientes paquetes:
xulrunner-2.0: Depende: libcairo2 (>= 1.10.2-1.1~bpo60+1) pero está instalado 1.10.0-1ubuntu2.
Las acciones siguientes resolverán estas dependencias

Mantener los paquetes siguientes en la versión actual:
1)     iceweasel [Sin instalar]
2)     xulrunner-2.0 [Sin instalar]

¿Acepta esta solución? [Y/n/q/?]n
Las acciones siguientes resolverán estas dependencias

Actualizar los paquetes siguientes:
1)     libcairo2 [1.10.0-1ubuntu2 (debian, now) -> 1.10.2-1.1~bpo60+1 (squeeze-backports)]

¿Acepta esta solución? [Y/n/q/?]y

Se instalarán los siguiente paquetes NUEVOS:
iceweasel libmozjs4d{a} xulrunner-2.0{a}
Se actualizarán los siguientes paquetes:
libcairo2
1 paquetes actualizados, 3 nuevos instalados, 0 para eliminar y 850 sin actualizar.
Necesito descargar 14,8 MB de ficheros. Después de desempaquetar se usarán 36,6 MB.
¿Quiere continuar? [Y/n/?] y

Como verán acepté la segunda solución y todo funcionó sin ningún contratiempo. Excepto que estaba en Inglés…

Chusmeando otro poco encontré el siguiente addon que soluciona el problema:

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/4.0.1/linux-x86_64/xpi/es-AR.xpi

Una vez hecho todo esto no queda mas que probar iceweasel 4.0.1