[LMDE]Solucionado problema con hora

Sigo haciéndole el service a una compu con LMDE y otro de los problemas con los que me encontré fue que la hora se desfasaba 3 horas para atrás…

Para solucionarlo necesitába sincronizar la hora del sistema con la del BIOS (que estaba bien) e hice lo siguiente:

1) Borré el archivo /etc/adjtime

$sudo rm /etc/adjtime

2) Colocamos la fecha y hora exactas en el sistema:

$sudo date –set “2013-02-05 12:33”

3) Actualizamos con hora de la BIOS y ¡Listo el Pollo!

$sudo hwclock –set –date=”2013-02-05 12:23″

Fuente salvadora del bardo: http://www.linux-party.com/index.php/35-linux/1732-cambiar-la-hora-y-la-fecha-al-sistema-linux

[LMDE] Reparando el error Note: root’s PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin E: Sub-process /usr/bin/dpkg returned an error code (2)

Ultimamente cada vez que queria usar sudo con algunos comandos,  saltaba el error:

Note: root’s PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin E: Sub-process /usr/bin/dpkg returned an error code (2)

Para arreglarlo seguí los siguientes pasos:

1) Edito el archivo environment: $sudo nano /etc/environment y agrego la línea:

PATH=”/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games”

Guardamos (con CTRL+X) y salimos

2) Actualizamos los datos: $source /etc/environment y ¡Listo el pollo!

Agregando Repositorios PPA a Debian

A veces nos suele pasar que nos encontramos en la necesidad de agregar algún repositorio PPA de Ubuntu y no tenemos ganas de ponernos a buscar la llave pública y dirección http del repositorio por separado. Si bien Ubuntu a tenido varios desaciertos (Aliarse con M$, cambiar Gnome por Unity, esquema escalonado de versiones, etc.) una gran pegada son los repositorios PPA, porque si bien hay algunos que opinan que son inseguros, no hay que negar que es una buena manera de ampliar modularmente nuestro S.O.

Bueno, dejemos de versear y vamos al grano: (El tutorial lo saco casi textualmente de acá. Yo sólo cambié lucid por precise para actualizar con los últimos paquetes)

Para añadir y poder trabajar con add-apt-repository vamos a utilizar un script creado por Anant Shrivastava.

El script es este:

01 #!/bin/bash
02 if [ $# -eq 1 ]
03 then
04 ppa_name=`echo “$1″ | cut -d”:” -f2 -s`
05 if [ -z “$ppa_name” ]
06 then
07 echo “PPA name not found”
08 echo “Utility to add PPA repositories in your debian machine”
09 echo “$0 ppa:user/ppa-name”
10 else
11 echo “$ppa_name”
12 echo “deb http://ppa.launchpad.net/$ppa_name/ubuntu lucid main” >> /etc/apt/sources.list
13 apt-get update >> /dev/null 2> /tmp/apt_add_key.txt
14 key=`cat /tmp/apt_add_key.txt | cut -d”:” -f6 | cut -d” ” -f3`
15 apt-key adv –keyserver keyserver.ubuntu.com –recv-keys $key
16 rm -rf /tmp/apt_add_key.txt
17 fi
18 else
19 echo “Utility to add PPA repositories in your debian machine”
20 echo “$0 ppa:user/ppa-name”
21 fi

Como podéis ver, el script trabaja con los repositorios de Lucid que son los más compatibles con Squeeze y LMDE.

Pasos para instalar el script:

* Guardamos el script, puedes copiarlo de arriba, abrir gedit, pegar el contenido y guardarlo como: add-apt-repository.sh

* Copiamos el script a /usr/bin/

1 sudo cp add-apt-repository.sh /usr/bin/add-apt-repository

* Cambiamos los permisos al script

1 sudo chmod o+x /usr/bin/add-apt-repository

* Cambiamos el dueño a root

1 sudo chown root:root /usr/bin/add-apt-repository

* Listo! ya podemos lanzar el comando de la manera habitual.

1 sudo add-apt-repository ppa:ppa-name

[LMDE] Placa BCM4313 en Kernel 3.2

Sigo con las actualizaciones en la compu de Veritux…  Cuando cambié de Kernel, además de reinstalar los drivers privativos de ATI, tuve que putear con la placa WIFI que no se conectaba. Intuí que era un problema con el Kernel porque al usar el sistema con Kernel 2.6.32-5 la placa se conectaba perfectamente. Cómo siempre, recurriendo a San Duckduckgo (Nada de San Google acá) encontré la solución en este blog http://www.mindwerks.net (Usé una combinación de lo que dice acá y acá)

Los pasos a seguir son los siguientes:

1) Descargué el driver de la BCM4313 desde acá http://www.broadcom.com/support/802.11/linux_sta.php

2) Cree la carpeta wl: $mkdir -p wl

3) Entré a la carpeta wl: $cd wl y descomprimí en esa carpeta el driver mediante tar: $tar xf ../hybrid-portsrc*-v5_100_82_38.tar.gz

4)  Emparchamos el archivo $patch -p0 src/wl/sys/wl_linux.c < bc_wl_abiupdate.patch
5) Compilar, instalar y cargar el módulo corregido.
$make
$sudo make install
$sudo depmod
$sudo modprobe wl
Con esto tuve funcionando la placa WIFI en LMDE con Kernel 3.2.

Saludos y espero que les sea útil.

LMDE El archivo «Release» ha expirado, ignorando

Tratando de actualizar la compu de una tal Veritux, me encontré con este error al apuntar los repositorios de LMDE a Testing…

E: El archivo «Release» ha expirado, ignorando http://debian.linuxmint.com/latest/dists/testing/InRelease

Investigando un poco llegué a una solución parcial y temporal que fue actualizar los repositorios mediante el siguiente comando:

$ sudo aptitude -o Acquire::Check-Valid-Until=”false” update

Con esta solución pude actualizar los repos, pero aclaro que fue algo temporal… Sigo investigando a ver si encuentro alguna forma que no sea esta para que vuelva a funcionar aptitude update

GIMP 2.7.4 (Con modo ventana Única) en LMDE o Debian

GIMP con Modo de Pantalla Única en LMDE

Acabo de enterarme por http://blog.desdelinux.net/ que salió una nueva versión de GIMP, específicamente la versión 2.7.4 que ademas de una renovada interfaz trae el tan esperado… ¡Modo de pantalla única! Todos los que por algún u otro motivo no nos sentíamos cómodos con las ventanas por separado vemos en ello una gran mejora.

Vamos a los tantos… Para instalar GIMP 2.7.4 en Debian debemos hacer lo siguiente:

1- Vamos a editar nuestros repositorios:

$sudo gedit /etc/apt/source.list

y al final del mismo agregamos el siguiente repositorio:

deb http://ppa.launchpad.net/matthaeus123/mrw-gimp-svn/ubuntu oneiric main

Guardamos y salimos.

2- Agregamos la llave pública:

$sudo apt-key adv –keyserver keyserver.ubuntu.com –recv-keys 405A15CB

3-Actualizamos los repositorios e instalamos:

$sudo apt-get update && sudo apt-get install gimp

 

NOTA: Para activar el modo de Ventana Única debemos ir al menú Ventanas/Modo de Ventana Única

 

¡Espero que lo disfruten!

Problemas con sudo y apt-get

Cada vez que quería usar apt o aptitude con sudo me saltaba este error:

dpkg: aviso: `ldconfig’ no se ha encontrado en el PATH o no es ejecutable.
dpkg: aviso: `start-stop-daemon’ no se ha encontrado en el PATH o no es ejecutable.
dpkg: error: 2 expected programs not found in PATH or not executable.
Note: root’s PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
E: Sub-process /usr/bin/dpkg returned an error code (2)

La solución fue muy simple:

1) Editamos el ~/.bashrc  con nuestro editor favorito. Por ejemplo nano ~/.bashrc

2) Agregamos la siguiente línea: export PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/usr/local/sbin:/usr/sbin:/sbin

Y con eso tendría que salir andando. 😉