Haciendo funcionar Ardour4 en Gnome-Shell y ArchLinux

Estuve puteando un poco con Ardour4 y Gnome-Shell. Al ejecutarlo se quedaba clavado:

ardour: [INFO]: CPU brand: Intel(R) Pentium(R) CPU B980 @ 2.40GHz
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: Loading default ui configuration file /etc/ardour4/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/alitux/.config/ardour4/ui_config
ardour: [INFO]: Loading color file /etc/ardour4/dark.colors

Por mas que buscaba en Internet no encontraba la solución. Me puse a revisar los archivos de configuración y en /home/alitux/.config/ardour4/ui_config encontré la solución:

Hay que modificar la línea:  <Option name=”color-file” value=”dark”/> por   <Option name=”color-file” value=”darks”/> o cualquier sanata en vez de “dark”. Aparentemente el tema no se lleva bien con gnome-shell.

Una vez que hacemos eso, Ardour4 vuelve a funcar como siempre. 🙂

PD: Si mal no recuerdo el problema también aparecía en KDE. Intuyo que la solución debería ser la misma.

 

[ArchLinux] Pacman está en uso, espere

Entrada bien cortita… Cuando trato de ejecutar pacman o yaourt me salta:

Pacman está en uso, espere

Me preparé unos mates, pero no pasó naranja, así que puse manos a la obra.

Primero nos fijamos que esté corriendo ningún proceso que involucre pacman

ps|grep pacman (¡Gracias @luuuciano!)

Si hay algún proceso, lo buscamos y vemos que hacer. 😛 Si no hay ningún proceso(como fue mi caso) hay que eliminar un archivo:

sudo rm /var/lib/pacman/db.lck

Y todo vuelve a la normalidad. 😉

 

[ArchLinux] Problema entre Kate y Pate Plugin

Kate

Tenía ganas de darle una oportunidad de usar a Kate como IDE para Python… Lógicamente lo primero que tenía que hacer era habilitar los complementos de python en Kate(Un tal Patê). Las instrucciones para instalarlo las saqué de acá.

Sin embargo, cada vez que ejecutaba Kate me saltaba que no podía ejecutar Pate. En consola encontré este mensaje que me parecía cuanto menos esclarecedor:

PyKDE4 import kdecoreImportError: No module named ‘PyKDE4’

Esto lo solucioné instalando kdebinding:

sudo pacman -S kdebindings-python

Y todo debería funcionar como corresponde.

 

El Turco Cafrune, ArchLinux y mt-daapd

Muchas de las cosas lindas de la vida empiezan en un asado. Hace un par de sábados estaba haciendo uno y me di cuenta que tenía ganas de escuchar a Cafrune, pero su música estaba en mi notebook. Sacar la computadora a la intemperie en Ushuaia no es una opción y, como buen geek, copiar la música a la SD de mi celular tampoco. Y ahí apareció mt-daapd que nos permite reproducir bajo demanda lo que tengamos en un servidor remoto.

La compañera Evita decía “Donde hay una necesidad nace un derecho”. Tenemos derecho es escuchar a Cafrune vía streaming usando tecnologías libres. 😉

Instrucciones:

1) Instalar mt-dappd mediante yaourt:

$yaourt -S mt-daaapd

2) Configurar mt-daapd

Para ello hay que editar el archivo /etc/mt-daapd/mt-daapd.conf

Para no perderse hay que buscar y modificar estas líneas:

admin_pw   mcowen

mp3_dir   /home/juanperon/Musica

servername    el nombre de tu servidor

runas   juanperon

NOTA IMPORTANTE: ¡En runas escribí tu nombre de usuario! Por defecto viene en nobody y eso hace que el mt-daapd no funcione. Me costó descubrirlo hasta que me puse a leer. 😉

Opcional(Agregar los ogg dentro de los archivos a indexar)

extensions .mp3,.m4a,.m4p,.ogg

Lógicamente guardamos el archivo.

Con todo ya podemos escuchar al Turco Cafrune mientras hacemos asado… Sin embargo, antes de activarlo podemos iniciar el daemon de avahi(para no andar recordando números de IP)

$sudo avahi-daemon &

Ahora si, podemos ejecutar mt-daapd

$mt-daapd -f

¿Y ahora con qué lo escucho?En Android podés usar DAAP Client https://f-droid.org/repository/browse/?fdfilter=daap&fdid=org.mult.daapEn Linux Amarok, Rhythmbox, etc…

[ArchLinux] Como solucionar problema entre akonadi y MariaDB 10.0.12

Después de actualizar mi Archlinux al último MariaDB me dejó de funcionar Akonadi(Con todo lo que ello implica: Mail, Calendario, contactos, etc.). Después de renegar un rato la solución fue más simple de lo que esperaba: Eliminar el archivo ~/.local/share/akonadi/mysql.conf

Eliminando este archivo y reiniciando akonadi todo vuelve a la normalidad 🙂

La data de como solucionar el problema la encontré acá